Modbus Firmware for IO3CC and IO8CC – Bootloader V4.x

Current version – V3.0

With this firmware, the IO3CC and IO8CC CardCage units can be used with the Modbus communications protocol.
Input and Output cards can be controlled over Ethernet.

 

It is possible to use any number of any type of card in the card cage, from filling the whole cage with a single type of card to mixing the four types in the same card cage.

 

Bootloader V4.x firmwares require Editor version 13.0.0 or higher to upload!

KissBox CPU versions are related to their boot-loader version and marked accordingly on the serial number label. A boot-loader version being V4.x for example indicates a V4 type CPU. When uploading firmware to a KissBox the Editor firmware wizard will also inform you of the Boot-loader/CPU version of the connected KissBox.

It is important to check that you load the right firmware in the right box. The IO3CC and IO8CC should only be loaded with Firmware specifically meant for it. Using a wrong firmware file will lead to erratic behavior. Accidentally loading an incorrect type of firmware will not physically damage the KissBox, it will however stop functioning. If this has happened, just load the correct firmware for the hardware version you have to render the KissBox operable again.

WARNING

The V4 bootloader hardware is not compatible with older bootloader V3.x firmwares. The installation of the wrong firmwares on V4 hardware¬†could “brick” the unit. It will have to be returned to the factory for repair.